API_​AttributeFolder

An attribute folder.

     struct API_AttributeFolder {
        API_AttrTypeID             typeID;
        GS::Array<GS::UniString>   path;
        GS::Guid                   guid;
    };

 

Members

typeID
Type of the attribute folder; this identifies the folder along with the path or guid field.
Refer to the API_AttrTypeID structure to see the possible attribute types.
path
Path of the folder, list of the names of the parent folders and the current in order.
In case of the root folder the path is empty.
guid
The globally unique identifier (GUID) of the folder; can be used for identifying the folder with ACAPI_Attribute_GetFolder.
Simply renaming or moving a folder in the folder structure, the guid stays the same.

 

Remarks

The name of the folder is not used.

 

Requirements

Version: API 26 or later
Header: APIdefs_Attributes.h

 

See Also

ACAPI_Attribute_GetFolder,
ACAPI_Attribute_CreateFolder,
ACAPI_Attribute_DeleteFolder,
ACAPI_Attribute_RenameFolder,
ACAPI_Attribute_GetFolderContent,
ACAPI_Attribute_Move,
API Types