API_​AttributeFolderPickerParams

Describes the type and the push check for creating an attribute folder picker in ACAPI_Attribute_CreateAttributeFolderPicker.

    struct API_AttributeFolderPickerParams{
        API_UserControlType                  type;
        short                                dialogID;
        short                                itemID;
        bool                                 drawIconAndTextToPushCheck;
    };

    

 

Members

type
Requested type of the user control.
dialogID
Id of the dialog of picker
itemID
Id of the push check of picker
drawIconAndTextToPushCheck
It is needed to draw icon and text of selected layer to push check or it is a simple button.

 

Requirements

Version: API 26 or later
Header: APIdefs_Interface.h

 

See Also

API Types

API_AttributeFolderPicker

ACAPI_Attribute_CreateAttributeFolderPicker