API_​AttributeManagerFormat

Represents the data of an attribute manager format.

    typedef struct {
        GSType                      fileType;
        GSType                      fileCreator;
        GS::UniString               popupText;
        GS::UniString               fileExtension;
    } API_AttributeManagerFormat;

 

Members

fileType
Macintosh file type (e.g. ‘TEXT’).
fileCreator
Creator on Macintosh (e.g. ‘GSAC’ for Archicad).
popupText
Description of the file type.
fileExtension
The extension used on Windows (e.g. “txt”).

 

Requirements

Version: API 26 or later
Header: APIdefs_Registration.h

 

See Also

ACAPI_Register_AttributeImportFormat
ACAPI_Install_AttrManagerImportMethod