Describes an attribute picker created in ACAPI_Interface_CreateAttributePicker, with getter and setter for the selected attribute and the hanlder of push check click event.
class API_AttributePicker{ public: API_AttributeIndex GetSelectedAttributeIndex (); void SetSelectedAttributeIndex (const API_AttributeIndex& index); bool Invoke (); bool Refresh (); API_UserControlType GetUserControlType ();;
Functions
- GetSelectedAttributeIndex ()
- Returns the index of the selected attribute.
- SetSelectedAttributeIndex ()
- Selects an attribute in the picker.
- Invoke ()
- Handles click event to the push check: shows the picker popup dialog.
- Refresh ()
- Refreshes the dialogicon and the caption in the pushcheck.
- GetUserControlType ()
- Returns the API_UserControlType param which was used to create itself.
Requirements
- Version: API 26 or later
- Header: APIdefs_Interface.h