API_​AttributePickerParams

Describes the type and the push check for creating an attribute picker in ACAPI_Interface_CreateAttributePicker.

    enum class PushCheckAppearance {
        ArrowIconAndText,
        ArrowOnly
    };
    enum class EmptySelectionBehaviour {
        SelectFirst,
        SelectNothing
    };
    enum class LockedLayersStatus {
        Disabled,
        Enabled
    };
    struct API_AttributePickerParams {
        API_UserControlType              type;
        short                            dialogID;
        short                            itemID;
        PushCheckAppearance              pushCheckAppearance;
        EmptySelectionBehaviour          emptySelectionBehaviour;
        LockedLayersStatus               lockedLayersStatus;
    };

Members

type
Requested type of the user control.
dialogID
Id of the dialog of picker
itemID
Id of the push check of picker
pushCheckAppearance
Defines whether the push check item should contain only an arrow icon pointing to right (PushCheckAppearance::ArrowOnly), or an icon and a text part also (PushCheckAppearance::ArrowIconAndText).
emptySelectionBehaviour
Tells what should happen with the selection during opening the popup, when the selected attribute index is not in the usable attribute set. Either the first attribute should be selected (EmptySelectionBehaviour::SelectFirst) or nothing should be selected in the appearing popup (EmptySelectionBehaviour::SelectNothing).
lockedLayersStatus
Layer specific data that controls the appearance of locked layers in the Layer Picker. The value LockedLayersStatus::Disabled tells that locked layers are gray and unselectable. The default value of this field is LockedLayersStatus::Enabled.

 

Requirements

Version: API 26 or later
Header: APIdefs_Interface.h

 

See Also

API Types
API_AttributePicker
ACAPI_Interface_CreateAttributePicker