User data record to assign to an attribute.
typedef struct { short dataVersion; unsigned short platformSign; GSFlags flags; Int32 filler_1; GSHandle dataHdl; } API_AttributeUserData;
Members
- dataVersion
- the version of the user data
- platformSign
- the platform the data was created on; defines the byte ordering (can be
GS::Win_Platform_Sign
,GS::Mac_Platform_Sign
orGS::Mactel_Platform_Sign
)
- flags
- not used
- dataHdl
- the actual user data (arbitrary size)
Remarks
Use the ACAPI_Attribute_SetUserData and ACAPI_Attribute_GetUserData functions to operate on this data.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Elements.h
See Also
ACAPI_Element_SetUserData, ACAPI_Element_GetUserData, API Types