The type of an attribute.
typedef enum { API_ZombieAttrID = 0, API_FirstAttributeID = 1, API_PenID = API_FirstAttributeID, API_LayerID = 2, API_LinetypeID = 3, API_FilltypeID = 4, API_CompWallID = 5, API_MaterialID = 6, API_LayerCombID = 7, API_ZoneCatID = 8, API_FontID = 9, API_ProfileID = 10, API_PenTableID = 11, API_DimStandID = 12, API_ModelViewOptionsID = 13, API_MEPSystemID = 14 API_OperationProfileID = 15, API_BuildingMaterialID = 16, API_LastAttributeID = API_BuildingMaterialID, } API_AttrTypeID;
Members
- API_ZombieAttrID
- Dummy attribute type.
- API_PenID
- Denotes a pen attribute.
- API_LayerID
- Denotes a layer attribute.
- API_LinetypeID
- Denotes a line type attribute.
- API_FilltypeID
- Denotes a fill attribute.
- API_CompWallID
- Denotes a composite wall attribute.
- API_MaterialID
- Denotes a material attribute.
- API_LayerCombID
- Denotes a layer combination attribute.
- API_ZoneCatID
- Denotes a zone category attribute.
- API_FontID
- Denotes a font attribute.
- API_ProfileID
- Denotes a custom profile attribute for walls, beams, and columns.
- API_PenTableID
- Denotes a named pen table attribute (a collection of 255 pens).
- API_DimStandID
- Denotes a dimension style attribute.
- API_ModelViewOptionsID
- Denotes a collection of model view options attributes.
- API_MEPSystemID
- Denotes a MEP System attribute.
- API_OperationProfileID
- Denotes an Energy Evaluation operation profile.
- API_BuildingMaterialID
- Denotes a building material attribute.
Remarks
This is a general constant which describes the different attributes types, and is used in most attribute-related operations.
Refer to the API_Attr_Head structure to get more details on it.
Requirements
- Version: API 1.3 or later
- Header: APIdefs_Attributes.h