Type of autotexts used in text and textual label elements.
typedef enum { APIAutoText_Fixed, APIAutoText_Custom, APIAutoText_Other, APIAutoText_All } API_AutotextType;
Members
- APIAutoText_Fixed
- Not editable part of project info category autotexts (Client, Project Name,…, Notes)
- APIAutoText_Custom
- Editable part of project info category autotexts (user can create any number custom autotexts, Custom 1, Custom 2, Custom 3 by default)
- APIAutoText_Other
- Other category autotexts (System, Drawing, Layout)
- APIAutoText_All
- All autotexts (APIAutoText_Fixed + APIAutoText_Custom + APIAutoText_Other)
Remarks
The API_AutotextType
values are used for filtering autotext types to be retrieved with the APIAny_GetAutoTextsID function.
Requirements
- Version: API 10 or later
- Header: APIdefs_Goodies.h