Parallel projection parameters.
typedef struct { double azimuth; API_SunAngleSettings sunAngSets; short projMod; short filler_1; Int32 filler_2; API_Tranmat tranmat; API_Tranmat invtranmat; double filler_3[8]; } API_AxonoPars;
Members
- azimuth
- rotation angle of the camera around the target
- sunAngSets
- Sun’s angle settings
- projMod
- projection type selected
- tranmat
- the transformation matrix to calculate projected coordinates
- invtranmat
- the inverse transformation matrix to calculate model coordinates from projected ones
Remarks
This structure corresponds to parameters set in the “3D Projection Settings…” dialog of Archicad, when a parallel view is selected.
Refer to the APIEnv_Get3DProjectionSetsID function to get the actual projection parameters.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h
See Also
APIEnv_Get3DProjectionSetsID, API_Tranmat, API_SunAngleSettings, API Types