API_​Base

The base of a non-static linear, angle or radial dimension element.

    typedef struct {
        API_ElemType       type;
        bool               line;
        bool               special;
        short              filler_1;
        Int32              filler_2;
        Int32              inIndex;
        API_Guid           guid;
        UInt32             node_id;
        short              node_status;
        short              node_typ;
    } API_Base;

 

Members

type
The type of the base element.
line
True in case of APINeig_WallOn, APINeig_WallPlOn, APINeig_BeamOn, APINeig_CeilOn, APINeig_RoofOn, APINeig_MeshOn, APINeig_HatchOn, APINeig_LineOn, APINeig_ArcOn, APINeig_SplineOn
special
True in case of APINeig_WallPl, APINeig_WallPlOn, APINeig_BeamHole, APINeig_WindHole, APINeig_DoorHole, APINeig_MeshRidge, APINeig_MeshRidgeOn
inIndex
InIndex of the base element’s node (see API_Neig).
guid Changed in API 11
The unique identifier of the base element.
node_id
Polygon vertex id (from the API_ElementMemo of the elements which have a polygon).
node_status
For internal use (reserved for section dim).
node_typ
For internal use (reserved for section dim).

 

Remarks

New in API 26 From version 26 the type of the typeID member was changed into API_ElemType.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Elements.h

 

See Also

API Types, API_Guid, API_DimBase