API_​Beam_​Hole

Describes a beam hole.

    typedef struct {
        API_BHoleTypeID     holeType;
        bool                holeContureOn;
        bool                filler_1;
        short               filler_2;
        Int32               holeID;
        Int32               filler_3;
        double              centerx;
        double              centerz;
        double              width;
        double              height;
    } API_Beam_Hole;

 

Members

holeType
Type of the hole (rectangular / circular).
holeContureOn
Show the hole’s contour in 2D?
filler_1
Reserved for later use.
filler_2
Reserved for later use.
holeID
ID of the hole, unique in the beam.
filler_3
Reserved for later use.
centerx
The ‘x’ location of the hole’s center relative to the beginning coordinate of the beam.
centerz
The ‘z’ location of the hole’s center relative to the top of the beam.
width
The width of the hole.
height
The height of the hole (effective only for the rectangular type).

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_BHoleTypeID, API_ElementMemo, API Types