API_​BeamPart

Section of a beam that crosses the room.

    typedef struct {
        API_Guid     guid;
        Int32        filler[2];
        double       tBeg;
        double       tEnd;
    } API_BeamPart;

 

Members

guid 17
GUID of the beam
tBeg
Beginning distance of the section from the beginning point of the beam
tEnd
End distance of the section from the beginning point of the beam

 

Remarks

The API_BeamPart structure is a member of API_RoomRelation. The following example shows how to interpret this data.

Room beam part
API_RoomRelation

    nBeamPart           2

    beamPart[0]
            tBeg     0.00
            tEnd     2.05

    beamPart[1]
            tBeg     0.30
            tEnd     4.00

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetRelations, API_RoomRelation, API Types