API_​BeamQuantity

Describes the different calculated values for beams.

    typedef struct {
        double     area;
        double     rightLength;
        double     leftLength;
        double     bottomSurface;
        double     topSurface;
        double     edgeSurfaceLeft;
        double     edgeSurfaceRight;
        double     edgeSurface;
        double     holesSurface;
        double     holesEdgeSurface;
        Int32      holesNumber;
        Int32      filler_1;
        double     crossSectionAreaCutBegin;
        double     crossSectionAreaCutEnd;
        double     volume;
        double     volume_cond;
        double     holesVolume;
        double     filler_2[6];
    } API_BeamQuantity;

 

Members

area New in API 23
area of the beam
rightLength
length of the beam on the right side of the reference line
leftLength
length of the beam on the left side of the reference line
bottomSurface
surface of the bottom of the beam
topSurface
surface of the top of the beam
edgeSurfaceLeft
surface of the beam on the left side of the reference line
edgeSurfaceRight
surface of the beam on the right side of the reference line
edgeSurface
surface of both ends of the beam
holesSurface
total surface of holes in the beam
holesEdgeSurface
total surface of hole edges in the beam
holesNumber
number of holes in the beam
crossSectionAreaCutBegin New in API 23
area of the beams begin cross section
crossSectionAreaCutEnd New in API 23
area of the beams end cross section
volume
volume of the beam
volume_cond Changed in API 13
conditional volume of the beam
holesVolume
total volume of holes in the beam

 

Remarks

See also the beam parameters for listing in Appendix A of the GDL Reference manual.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types, API_CalcRulesPrefs