API_​BeamSegmentQuantity

Describes the different calculated values for beam segments.

    typedef struct {
        double     endSurface;
        double     leftSurface;
        double     rightSurface;
        double     bottomSurface;
        double     topSurface;

        double     length;
        double     leftLength;
        double     rightLength;

        Int32      crossSectionAreaCutBegin;
        double     crossSectionAreaCutEnd;

        double     volume;

        Int32      holesNumber;
        Int32      filler_1;

        double     holesSurface;
        double     holesEdgeSurface;
        double     holesVolume;
        Int32      filler_2[8];
    } API_BeamSegmentQuantity;

 

Members

endSurface
surface of the ends of the beam segment
leftSurface
surface of the left side of the beam segment
rightSurface
surface of the right side of the beam segment
bottomSurface
surface of the bottom of the beam segment
topSurface
surface of the top of the beam segment
length
length of the beam segment
leftLength
length of the beam segment on the left side
rightLength
length of the beam segment on the right side
crossSectionAreaCutBegin
area of the beam segment cut section at the beginning of the segment
crossSectionAreaCutEnd
area of the beam segment cut section at the end of the segment
volume
volume of the beam segment
conditionalVolume
conditional volume of the beam segment
holesNumber
total number of holes in the beam segment
holesSurface
total surface of holes in the beam segment
holesEdgeSurface
total surface of hole edges in the beam segment
holesVolume
total volume of holes in the beam segment

 

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types, API_CalcRulesPrefs