API_​BeamSegmentRelation

Structure for retrieving connection data of a beam segment.

    typedef struct {
        API_Coord                         **coords;
        Int32                             **pends;
        API_PolyArc                       **parcs;
        Int32                             filler_1;
        API_Polygon                       connPoly;
        GS::Array<API_ConnectionGuidItem> *conBeg;
        GS::Array<API_ConnectionGuidItem> *conEnd;
        GS::Array<API_ConnectionGuidItem> *conRef;
        GS::Array<API_ConnectionGuidItem> *con;
        GS::Array<API_ConnectionGuidItem> *conX;
        Int32                             filler_2[8];
    } API_BeamSegmentRelation;

 

Members

coords
Coordinates of the modified outline polygon
pends
Indices of the end coordinates of the subpolygons
parcs
Arc segments of the modified outline polygon (used with curved beams API 17)
connPoly
Modified outline polygon due to the connections
conBeg
List of beam segments connected to the beginning point of the beam segment with their beginning or end point.
conEnd
List of beam segments connected to the end point of the beam segment with their beginning or end point.
conRef
List of beam segments connected with their reference line to the beginning or the end point of the beam segment.
con
List of beam segments connected to the reference line of the beam segment not at the endpoints.
conX
List of beam segments having intersection with the reference line of the beam segment.

Remarks

To learn more about the usage of the beam segment relation structure please refer to the ACAPI_Element_GetRelations function.

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetRelations, API_BeamRelation, API_WallRelation, API_CWPanelRelation, API_ConnectionGuidItem, API_Coord, API_PolyArc, API_Polygon, API Types