API_​BeamSegmentType

Represents an segment of the beam element.

    typedef struct {
        API_Elem_Head                      head;
        API_Guid                           owner;
        API_AssemblySegmentData            assemblySegmentData;
        API_OverriddenAttribute            leftMaterial;
        API_OverriddenAttribute            topMaterial;
        API_OverriddenAttribute            rightMaterial;
        API_OverriddenAttribute            bottomMaterial;
        API_OverriddenAttribute            endsMaterial;
	bool                               materialsChained;
    } API_BeamSegmentType;

 

Members

head
General element header.
owner
The guid of the owner beam.
assemblySegmentData
General informations about segment.
leftMaterial
The material override structure of the left side of the beam.
topMaterial
Material override structure of the top of the beam.
rightMaterial
Material override structure of the right side of the beam.
bottomMaterial
Material override structure of the bottom of the beam.
endsMaterial
The material override structure of the beginning and end side of the beam.
materialsChained
Are surface materials chained?

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

API_BeamType API_OverriddenAttribute, API_Elem_Head,
API_Element, API_ElementMemo
API_BeamSegmentRelation
Element Manager, API Types