API_​BeamType

Represents a beam element.

    typedef struct {
        API_Elem_Head                      head;
        short                              aboveViewLinePen;
        API_AttributeIndex                 aboveViewLineType;
        API_AttributeIndex                 refLtype;
        short                              refPen;
        short                              cutContourLinePen;
        API_AttributeIndex                 cutContourLineType;
        Int32                              sequence;
        API_PenOverrideType                penOverride;
        API_StoryVisibility                visibility;
        API_LinkToSettings                 linkToSettings;
        API_BHoleTypeID                    holeType;
        bool                               holeContureOn;
        bool                               isAutoOnStoryVisibility;
        double                             holeWidth;
        double                             holeHeight;
        double                             holeLevel;
        double                             offset;
        double                             level;
        API_BeamVisibleLinesID             showContourLines;
        API_BeamVisibleLinesID             showReferenceAxis;
        API_Coord                          begC;
        API_Coord                          endC;
        double                             curveAngle;
        API_AttributeIndex                 verticalCurveHeight;
        API_AttributeIndex                 hiddenLineType;
        short                              hiddenLinePen;
        API_AttributeIndex                 belowViewLineType;
        short                              belowViewLinePen;
        bool                               isFlipped;
        bool                               isSlanted;
        double                             slantAngle;
        double                             axisRotationAngle;
        API_BeamShapeTypeID                beamShape;
        API_ElemDisplayOptionsID           displayOption;
        API_ElemViewDepthLimitationsID     viewDepthLimitation;
        API_ElemViewDepthLimitationsID     uncutProjectionMode;
        API_ElemViewDepthLimitationsID     overheadProjectionMode;
        UInt32                             nSegments;
        UInt32                             nCuts;
        UInt32                             nSchemes;
        UInt32                             nProfiles;

        bool                               useCoverFill;
        bool                               useCoverFillFromSurface;
        bool                               coverFillOrientationComesFrom3D;
        bool                               filler_6;
        API_AttributeIndex                 coverFillType;
        short                              coverFillForegroundPen;
        short                              coverFillBackgroundPen;
        short                              filler_7;
        API_CoverFillTransformationTypeID  coverFillTransformationType;
        Int32                              filler_8;
        API_CoverFillTransformation        coverFillTransformation;
    } API_BeamType;

 

Members

head
General element header.
aboveViewLinePen
The pen index.
aboveViewLineType
The linetype index.
refLtype
The linetype index of the reference line.
refPen
The pen index of the reference line.
cutContourLinePen
The pen index of the cut lines of the beam.
cutContourLineType 5.1
The line type index of the beam section countour line.
sequence Featuring API 17
Sequence is required when two beams meet with the same priority or when 3 or more beams meet in a junction. It’s actual values can be between 0 and 999.
penOverride Featuring API 17
Cut fill pens set in the used structure (building material, complex profile) can be overridden on the element level.
visibility
The option to define which stories display the beam. 6.1
linkToSettings Featuring API 11
Mode of linking to home story.
holeType
The shape of the beam hole (see API_BHoleTypeID).
holeContureOn
Show the hole’s conture on the plan.
isAutoOnStoryVisibility Featuring API 10
Recalculate the story visibility automatically according to the actual elevation of the beam.
holeWidth
The default width of the holes.
holeHeight
The default height of the holes (effective only for the rectangle type – holeType is APIBHole_Rectangular).
holeLevel
The default level of the holes: the distance between the center of the hole and the top of the beam.
offset
The offset of beam’s reference line from the center.
level
The top height of the beam relative to the floor level.
showContourLines
showReferenceAxis
begC
The beginning (start) coordinate of the beam.
endC
The end coordinate of the beam.
curveAngle API 17
The arc angle of the curved beam between begC and endC (negative value results an arc on the opposite side). This value is always zero for straight beams.
verticalCurveHeight Featuring API 23
The height of the vertical curvature of the beam.
hiddenLineType Featuring API 23
hiddenLinePen Featuring API 23
belowViewLinePen Featuring API 10
Pen index of the uncut lines.
belowViewLineType Featuring API 11
Linetype of the uncut lines.
isFlipped Featuring API 20
Defines whether the beam is mirrored. Applies to profiled beams only.
isSlanted Featuring API 10
Defines whether the beam is slanted.
slantAngle Featuring API 10
Slant angle.
axisRotationAngle Featuring API 10
Profile rotating angle around it’s center line.
beamShape Featuring API 23
Type to define if beam is straight, horizontally or vertically curved.
displayOption Featuring API 10
Display options of the element on the floor plan (see API_ElemDisplayOptionsID).
viewDepthLimitation Featuring API 10
Defines the range within the element is shown on the floor plan (see API_ElemViewDepthLimitationsID).
uncutProjectionMode Featuring API 23
Uncut projection mode.
overheadProjectionMode Featuring API 23
Overhead projection mode.
nSegments Featuring API 17
Number of segments.
nCuts Featuring API 17
Number of cuts.
nSchemes Featuring API 17
Number of schemes.
nProfiles Featuring API 17
Number of profiles.
useCoverFill Featuring API 23
Use Floor plan fill.
useCoverFillFromSurface Featuring API 23
Use the fill attribute assigned to the surface material of the element.
coverFillOrientationComesFrom3D Featuring API 23
Use cover fill orientation from 3D element view.
coverFillType Featuring API 23
Type of the fill.
coverFillForegroundPen Featuring API 23
Foreground pen of the cover fill.
coverFillBackgroundPen Featuring API 23
Background pen of the cover fill.
coverFillTransformationType Featuring API 23
TransformationType of the fill (see API_CoverFillTransformationTypeID).
coverFillTransformation Featuring API 23
Orientation and distortion parameters of the cover fill. (see API_CoverFillTransformation).

 

Remarks

Featuring API 17  In Archicad 17 the type of the elements’ structure is defined with the new modelElemStructureType member. The related attribute indices are separated into buildingMaterial and profileAttr.

Featuring API 17  In Archicad 17 the the elements’ cut fill foreground and background pens inherit from the element structure, and can be overridden on the element level.

Featuring API 17  In Archicad 17 the the elements’ surface materials inherit from the element structure, and can be overridden on the element level.

For beam related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_BHoleTypeID, API_Coord, API_StoryVisibility, API_LinkToSettings
API_ElemDisplayOptionsID, API_ElemViewDepthLimitationsID
API_AttributeIndex, API_Elem_Head, API_Element, API_ElementMemo
API_Gable
API_BeamSegmentType, API_AssemblySegmentData
API_AssemblySegmentSchemeData, API_AssemblySegmentProfileData
API_BeamRelation
Element Manager, API Types