API_​Box

Rectangular region of the model.

    typedef struct {
        double     xMin;
        double     yMin;
        double     xMax;
        double     yMax;
    } API_Box;

 

Members

xMin, yMin
bottom / left corner
xMax, yMax
top / right corner

 

Remarks

It is a rectangle in model coordinates. Always expressed in meters, if no other instructions in the corresponding documentation.

For the integer type representation refer to the API_Rect structure or to the APIDb_PointToCoordID and APIDb_CoordToPointID functions for the conversion algorithms.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Base.h

 

See Also

APIDb_CoordToPointID, APIDb_PointToCoordID, API_Rect, API Types