API_​Box3D

Rectangular region of the model with Z extent.

    typedef struct {
        double     xMin;
        double     yMin;
        double     zMin;
        double     xMax;
        double     yMax;
        double     zMax;
    } API_Box3D;

 

Members

xMin, yMin
bottom / left corner on the lower plane
xMax, yMax
top / right corner on the upper plane
zMin, zMax
bottom / top level

 

Remarks

It is a rectangle in model coordinates, with vertical information. Always expressed in meters, if no other instructions in the corresponding documentation.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Base.h

 

See Also

API_Box, API Types