API_​BuildingMaterialType

Building Material type attribute representation.

    typedef struct {
        API_Attr_Head             head;
        GS::UniString             *id;
        GS::UniString             *manufacturer;
        GS::UniString             *description;
        Int32                     connPriority;
        API_AttributeIndex        cutFill;
        short                     cutFillPen;
        short                     cutFillBackgroundPen;
        API_AttributeIndex        cutMaterial;
        API_FillOrientationID     cutFillOrientation;
        Int32                     filler_0;
        double                    thermalConductivity;
        double                    density;
        double                    heatCapacity;
        double                    embodiedEnergy;
        double                    embodiedCarbon;
        bool                      showUncutLines;
        bool                      doNotParticipateInCollDet;
        bool                      filler_1[6];
    } API_BuildingMaterialType;

 

Members

head
Contains the name and the index of the building material.
id Changed in API 18
The id of the building material.
manufacturer Changed in API 18
The manufacturer of the building material.
description Changed in API 18
The description of the building material.
connPriority
The priority of the building material. Used when multiple elements intersect, the higher priority element will be shown at the intersection.
cutFill
Index of the building material’s cut fill.
cutFillPen
Index of the building material’s cut fill foreground pen.
cutFillBackgroundPen
Index of the building material’s cut fill background pen.
cutMaterial
Index of the building material’s cut material.
cutFillOrientation
Orientation of the building material’s cut fill.
thermalConductivity
Thermal Conductivity of the building material.
density
Density of the building material.
heatCapacity
Heat capacity of the building material.
embodiedEnergy Changed in API 18
Embodied energy in the building material.
embodiedCarbon Changed in API 18
Embodied carbon in the building material.
showUncutLines Changed in API 18
Show Contours in Model Views.
doNotParticipateInCollDet Changed in API 18
Specifies if the building material does not participate in collision detection.

 

Remarks

Most of the fields in this structure correspond to the items of the Building Material dialog in Archicad.

API 17 Note that in AC17 the Energy Evaluation property parameters (thermalConductivity, density and heatCapacity) have been removed from the API_FilltypeType, they are now part of this structure.

 

Requirements

Version: API 17 or later
Header: APIdefs_Attributes.h

 

See Also

API_Attr_Head, API_Attribute, API_AttributeDef, API_AttributeIndex,
Attribute Manager, API Types