API_​CalcAreaFormat

The API_CalcUnitPrefs structure contains this structure.

    typedef struct {
        API_AreaTypeID          unit;
        API_ExtraAccuracyID     accuracy;
        short                   decimals;
        short                   filler_1;
    } API_CalcAreaFormat;

 

Members

unit
The type of the area measurement unit.
accuracy
European methods for rounding decimal values.
decimals
Number of decimals for area measurement unit [0..4]

 

Requirements

Version: API 22 or later
Header: APIdefs_Environment.h

 

See Also

API_CalcLengthFormat
API_CalcVolumeFormat
API_CalcAngleFormat
API_CalcUnitPrefs
APIEnv_GetPreferencesID
API Types