API_​CalcFormat

The API_CalcUnitPrefs structure contains this structure.

    typedef struct {
        API_UnitTypeID          unit;
        API_ExtraAccuracyID     accuracy;
        short                   decimals;
        short                   roundInch;
        Int32                   filler_1;
    } API_CalcFormat;

 

Members

unit
The type of the length measurement unit.
accuracy
European methods for rounding decimal values.
decimals
Number of decimals for length measurement unit [0..4]
roundInchFeaturing API 12
Fractions in case of the unit is feet or fractional inches [None, 1/2, 1/4,…1/64]

 

Remarks

none

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Environment.h

 

See Also

API_CalcUnitPrefs
APIEnv_GetPreferencesID
API Types