API_​CalcLengthFormat

The API_CalcUnitPrefs structure contains this structure.

    typedef struct {
        API_LengthTypeID        unit;
        API_ExtraAccuracyID     accuracy;
        short                   decimals;
        short                   roundInch;
    } API_CalcLengthFormat;

 

Members

unit
The type of the length measurement unit.
accuracy
European methods for rounding decimal values.
decimals
Number of decimals for length measurement unit [0..4]
roundInch
fractional inches (1, 2, 4, 8, 16, 32, 64)

 

Requirements

Version: API 22 or later
Header: APIdefs_Environment.h

 

See Also

API_CalcAreaFormat
API_CalcVolumeFormat
API_CalcAngleFormat
API_CalcUnitPrefs
APIEnv_GetPreferencesID
API Types