The representation of the Calculation Rules on the Preferences / Calculation Units & Rules tab page.
typedef struct { GS::Array<API_ConditionalElementRule> elementRules; GS::HashSet<API_AttributeIndex> wallInsulationFills; GS::HashSet<API_AttributeIndex> wallAirFills; GS::HashSet<API_AttributeIndex> roofInsulationFills; GS::HashSet<API_AttributeIndex> shellInsulationFills; } API_CalcRulesPrefs;
Members
- elementRules
- Conditional calculation rules for elements.
- wallInsulationFills
- Wall insulation fill indices.
- wallAirFills
- Wall air fill indices.
- roofInsulationFills
- Roof insulation fill indices.
- shellInsulationFills
- Shell insulation fill indexes.
Remarks
This structure is used by the APIEnv_GetPreferencesID function to get the settings of the Calculation Rules on the Preferences / Calculation Units & Rules preferences page.
From API 25 BNZeroMemory
, BNClear
or memset
should not be used to initialize an object of this structure.
Requirements
- Version: API 13.0 or later
- Header: APIdefs_Environment.h
See Also
API_AttributeIndex, API_WallQuantity, API_SlabQuantity, API_RoofQuantity, API_BeamQuantity, API Types