API_​CalcUnitPrefs

The representation of the Project Preferences / Calculation Units & Rules tab page.

    typedef struct {
        API_CalcLengthFormat     length;
        API_CalcAreaFormat       area;
        API_CalcVolumeFormat     volume;
        API_CalcAngleFormat      angle;
        bool                     useDisplayedValues;
        bool                     filler_0[15];
    } API_CalcUnitPrefs;

 

Members

length Changed in API 22
Length preferences.
area Changed in API 22
Area preferences.
volume Changed in API 22
Volume preferences.
angle
Angle preferences.
useDisplayedValues API version 20
Represents the “Calculate Totals by” RadioButton.
  • true means that Archicad should use the displayed values in calculations. This way the calculations can be verified manually.
  • false means that Archicad should use the exact values (in double precision) in calculations.

 

Remarks

This structure is used by the APIEnv_GetPreferencesID function to get the settings of the Calculation Units & Rules preferences page.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Environment.h

 

See Also

API Types