API_​CamSetType

Represents a camera set.

    typedef struct {
        API_Elem_Head          head;
        GS::uchar_t            name [API_UniLongNameLen];
        API_PersCamSetPars     perspPars;
        bool                   active;
        bool                   filler_2[7];
        API_Guid               firstCam;
        API_Guid               actCam;
    } API_CamSetType;

 

Members

head
General element header.
name[API_UniLongNameLen] Modified in 18
Unicode (UTF-16) name of the camera set.
perspPars
Parameters of the perspective camera.
active
Is this the active camera set?
firstCam 11
First camera in the camera set.
actCam 11
Actual camera in the camera set.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head, API_PersCamSetPars, API_Element,
Element Manager, API Types