API_​ChangeParamType

Parameters to change a value in a Library Part parameter list.

    typedef struct {
        char            name [API_NameLen];
        short           index;
        short           filler_1;
        Int32           ind1;
        Int32           ind2;
        GS::uchar_t     *uStrValue;
        double          realValue;
        GS::uchar_t     valueDescription [API_UAddParNumDescLen];
    } API_ChangeParamType;

 

Members

name[API_NameLen]
parameter name. Optional the index field is used when it is not filled.
index
parameter index. Required if the name field is empty.
ind1
1st dimension of array (in case of array modifier)
ind2
2nd dimension of array (in case of array modifier)
uStrValue Changed in API 11
Unicode string parameter value in UTF-8 encoding
realValue
numeric parameter value
valueDescription[API_UAddParNumDescLen]New in API 18
Unicode parameter value description string in UTF-16 encoding.

 

Remarks

The target variable can be identified either by name or index. In case of an array variable the ind1 and ind2 fields must be passed to address the array position.

The new values should be passed in the strValue or realValue fields, depending on the type of the referenced variable.

See the APIAny_ChangeAParameterID and APIAny_OpenParametersID functions for utilization.

  

Requirements

Version: API 2.1 or later
Header: APIdefs_Goodies.h

 

See Also

APIAny_OpenParametersID, APIAny_ChangeAParameterID, API Types