Defines a transformation for the clipping.
typedef struct { double x0; double y0; double scale; double angle; short floor; short filler_0[3]; } API_ClipTran;
Members
- x0
- offset in
x
direction - y0
- offset in
y
direction - scale
- scale factor
- angle
- rotation angle
- floor
- floor index
Remarks
This is the second parameter of the APIDb_DoClipID function; defines a transformation for the clipping region.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Database.h