API_​CollisionDetectionSettings

Collision detection settings used by ACAPI_Element_GetCollisions

    typedef struct {
        double       volumeTolerance;
        bool         performSurfaceCheck;
        double       surfaceTolerance;
    } API_CollisionDetectionSettings;

 

Members

volumeTolerance
Intersection body volume greater then this value will be considered as a collision.
performSurfaceCheck
Enables surface collision check. If disabled the surfaceTolerance value will be ignored.
surfaceTolerance
Intersection body surface area greater then this value will be considered as a collision.

 

Requirements

Version: API 22 or later
Header: APIdefs_Goodies.h