Various options for color depth.
typedef enum { APIColorDepth_FromSourceImage = -1, APIColorDepth_BW, APIColorDepth_16C, APIColorDepth_256C, APIColorDepth_16G, APIColorDepth_256G, APIColorDepth_4C, APIColorDepth_4G, APIColorDepth_ThC, APIColorDepth_MiC, APIColorDepth_MiCP, APIColorDepth_64KC, APIColorDepth_TC24, APIColorDepth_TC32, } API_ColorDepthID;
Members
- APIColorDepth_FromSourceImage
- Use the color depth from the source image.
- APIColorDepth_BW
- Black & white.
- APIColorDepth_16C
- 16 colors.
- APIColorDepth_256C
- 256 colors.
- APIColorDepth_16G
- 16 grays.
- APIColorDepth_256G
- 256 grays.
- APIColorDepth_4C
- 4 colors.
- APIColorDepth_4G
- 4 grays.
- APIColorDepth_ThC
- Thousands of colors.
- APIColorDepth_MiC
- Millions of colors.
- APIColorDepth_MiCP
- Millions of colors+.
- APIColorDepth_64KC
- 64K colors.
- APIColorDepth_TC24
- True color – 24 bit.
- APIColorDepth_TC32
- True color – 32 bit.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h