API_​ColumnQuantity

Describes the different calculated values for columns.

    typedef struct {
        double     coreSurface;
        double     veneSurface;
        double     coreVolume;
        double     veneVolume;
        double     minHeight;
        double     maxHeight;
        double     perimeter;
        double     area;
        double     coreGrossSurf;
        double     veneGrossSurf;
        double     crossSectionAreaCutBegin;
        double     crossSectionAreaCutEnd;
        double     coreGrossVolume;
        double     veneGrossVolume;
        double     coreTopSurf;
        double     coreBotSurf;
        double     veneTopSurf;
        double     veneBotSurf;
        double     coreGrossTopBotSurf;
        double     veneGrossTopBotSurf;
        double     filler_1[2];
    } API_ColumnQuantity;

 

Members

coreSurface
surface of the column core
veneSurface
surface of the column veneer
coreVolume
volume of the column core
veneVolume
volume of the column veneer
minHeight
minimum height of the column
maxHeight
maximum height of the column
perimeter
perimeter of the column
area
area of the column
coreGrossSurf
gross surface of the core
veneGrossSurf
gross surface of the veneer
crossSectionAreaCutBegin New in API 23
area of the columns begin cross section
crossSectionAreaCutEnd New in API 23
area of the columns end cross section
coreGrossVolume
gross volume of the core
veneGrossVolume
gross volume of the veneer
coreTopSurf
surface of the core top 6.1
coreBotSurf
surface of the core bottom 6.1
veneTopSurf
surface of the veneer top 6.1
veneBotSurf
surface of the veneer bottom 6.1
coreGrossTopBotSurf
gross surface of the core top and bottom 6.1
veneGrossTopBotSurf
gross surface of the veneer top and bottom 6.1

 

Remarks

See also the column description in Appendix A of the GDL Reference manual.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types