API_​ColumnSegmentType

Represents an segment of the column element.

    typedef struct {
        API_Elem_Head                      head;
        API_Guid                           owner;
        API_AssemblySegmentData            assemblySegmentData;
        API_OverriddenAttribute            extrusionSurfaceMaterial;
        API_OverriddenAttribute            endsMaterial;
        bool                               materialsChained
        API_AttributeIndex                 venBuildingMaterial;
        API_VeneerTypeID                   venType;
        double                             venThick
    } API_ColumnSegmentType;

 

Members

head
General element header.
owner
Guid of the owner column.
assemblySegmentData
General informations about segment.
extrusionSurfaceMaterial
The column’s segment material override structure.
endsMaterial
The material override structure of the beginning and end side of the column’s segment.
materialsChained
Are surface materials chained?
venBuildingMaterial
Building Material index of column’s segment veneer’s hatch. Used only, if structure type is API_BasicStrucure.
venType
The type of the column’s segment veneer.
venThick
The thickness of the column’s segment veneer.
.

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also



API_AttributeIndex, API_Elem_Head, API_Element, API_ElementMemo
API_Gable, API_ColumnType
Element Manager, API Types