API_​ColumnType

Represents a column element.

    typedef struct {
        API_Elem_Head                      head;
        short                              corePen;
        API_PenOverrideType                penOverride;
        short                              belowViewLinePen;
        API_AttributeIndex                 belowViewLineType;
        API_AttributeIndex                 contLtype;
        bool                               wrapping;
        API_ZoneRelID                      zoneRel;
        short                              coreSymbolType;
        short                              coreAnchor;
        double                             height;
        double                             bottomOffset;
        double                             topOffset;
        API_AttributeIndex                 venLineType;
        short                              venLinePen;
        short                              coreSymbolPen;
        double                             coreSymbolPar1;
        double                             coreSymbolPar2;
        API_StoryVisibility                visibility;
        API_LinkToSettings                 linkToSettings;
        short                              relativeTopStory;
        API_AttributeIndex                 hiddenLineType;
        short                              hiddenLinePen;
        API_Coord                          origoPos;
        double                             axisRotationAngle;
        short                              aboveViewLinePen;
        API_AttributeIndex                 aboveViewLineType;
        bool                               isAutoOnStoryVisibility;
        bool                               isSlanted;
        bool                               isFlipped;
        double                             slantAngle;
        double                             slantDirectionAngle;
        API_ElemDisplayOptionsID           displayOption;
        API_ElemViewDepthLimitationsID     viewDepthLimitation;
        UInt32                             nCuts;
        UInt32                             nSegments;
        UInt32                             nSchemes;
        UInt32                             nProfiles;
        bool                               useCoverFill;
        bool                               useCoverFillFromSurface;
        bool                               coverFillOrientationComesFrom3D;
        bool                               filler_5;
        API_AttributeIndex                 coverFillType;
        short                              coverFillForegroundPen;
        short                              coverFillBackgroundPen;
        short                              filler_6;
        API_CoverFillTransformationTypeID  coverFillTransformationType;
        Int32                              filler_7;
        API_CoverFillTransformation        coverFillTransformation;
    } API_ColumnType;

 

Members

head
General element header
corePen
The pen index of the core
penOverride Featuring API 17
Cut fill pens set in the used structure (building material, complex profile) can be overridden on the element level.
belowViewLinePen
The pen index of the column’s contour in 3D
belowViewLineType Featuring API 11
Linetype of the uncut lines
contLtype
The line type index of core
wrapping
Defines the wall wrapping. If true, the wall wraps around the column
zoneRel
Defines the column’s relation to zones (see API_ZoneRelID)
coreSymbolType
Determines the display of the column on the floor plan:
1

Plain

2

Slash

3

X

4

CrossHair 6.1

coreAnchor
Anchor point of core:
0
1
2
3
4
5
6
7
8
height
The height of the column
bottomOffset
The column base level relative to the floor level
topOffset Featuring API 17
The offset from top floor if column is top linked
venLinetype 6.1
The line type index of veneer line
venLinePen 6.1
The color index of veneer line
coreSymbolPen 6.1
The color index of column cross line
coreSymbolPar1 6.1
The length of the crosshair outside the column’s contour line
coreSymbolPar2 6.1
The distance of the crosshair from the column’s center
visibility Featuring API 10
Defines on which floor the given element is visible (see API_StoryVisibility)
linkToSettings Featuring API 11
Mode of linking to home story.
relativeTopStory Featuring API 17
The top linked story (relative to home story). Negative values are invalid. 0 = not top linked.
hiddenLineType Featuring API 17
hiddenLinePen Featuring API 17
The top linked story (relative to home story). Negative values are invalid. 0 = not top linked.
origoPos
The position of the column
axisRotationAngle
The angle of rotation around the axis of the column (in radian)
aboveViewLinePen Featuring API 10
Pen index of the overhead lines
aboveViewLineType Featuring API 10
Linetype of the overhead lines
isAutoOnStoryVisibility Featuring API 10
If set to true, the application will automatically provide the story dependent visibility of the element (if the element is physically on a story, it will be shown on that story)
isSlanted Featuring API 10
Defines whether the column is slanted or vertical
isFlipped New in API 22
Flipped column.
slantAngle Featuring API 10
Slant angle (in radian)
slantDirectionAngle Featuring API 10
The rotation angle of the column on the horizontal plane (in radian)
displayOption Featuring API 10
Display options of the element on the floor plan (see API_ElemDisplayOptionsID)
viewDepthLimitation Featuring API 10
Defines the range within the element is shown on the floor plan (see API_ElemViewDepthLimitationsID)
nCuts Featuring API 17
Number of cuts.
nSegments Featuring API 17
Number of segments.
nSchemes Featuring API 17
Number of schemes.
nProfiles Featuring API 17
Number of profiles.
useCoverFill Featuring API 23
Use Floor plan fill.
useCoverFillFromSurface Featuring API 23
Use the fill attribute assigned to the surface material of the element.
coverFillOrientationComesFrom3D Featuring API 23
Use cover fill orientation from 3D element view.
coverFillType Featuring API 23
Type of the fill.
coverFillForegroundPen Featuring API 23
Foreground pen of the cover fill.
coverFillBackgroundPen Featuring API 23
Background pen of the cover fill.
coverFillTransformationType Featuring API 23
TransformationType of the fill (see API_CoverFillTransformationTypeID).
coverFillTransformation Featuring API 23
Orientation and distortion parameters of the cover fill. (see API_CoverFillTransformation).

 

Remarks

Featuring API 17  In Archicad 17 the type of the elements’ structure is defined with the new modelElemStructureType member. The related attribute indices are separated into buildingMaterial and profileAttr.

Featuring API 17  In Archicad 17 the the elements’ cut fill foreground and background pens inherit from the element structure, and can be overridden on the element level.

Featuring API 17  In Archicad 17 the the elements’ surface materials inherit from the element structure, and can be overridden on the element level.

For column related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head, API_AttributeIndex, API_ZoneRelID, API_Coord, API_StoryVisibility, API_LinkToSettings
API_ElemDisplayOptionsID, API_ElemViewDepthLimitationsID
API_Element, API_Gable, API_ElementMemo
API_ColumnSegmentType, API_AssemblySegmentData
API_AssemblySegmentSchemeData, API_AssemblySegmentProfileData
Element Manager, API Types