API_​ComponentRefType

The component reference record.

    typedef struct {
        Int32      libIndex;
        Int32      setIndex;
        Int32      index;
        Int32      status;
        double     quantity;
        Int32      filler_3[8];
    } API_ComponentRefType;

 

Members

libIndex
Index of the library part where the component was declared
setIndex
Index of the listing database set, if status is equal to APIDBRef_Normal.
index
This member depends on the status field. If status equals APIDBRef _Normal, then index is index of the component in the set, if status equals APIDBRef_Local, then index is index of the component in the library part. 
status
This member is status of component(APIDBRef__Normal, APIDBRef__Local, APIDBRef_Deleted).
quantity
Calculated quantity of component.

 

Remarks

This structure is used when you want to get the components of an element. These components are in the property objects of the element. See the ACAPI_Element_GetComponents function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API Types