API_​CompWallType

Composite fill attribute representation.

    typedef struct {
        API_Attr_Head     head;
        double            totalThick;
        short             nComps;
        short             filler_1;
        Int32             filler_2;
    } API_CompWallType;

 

Members

head
Contains the name and the index of the attribute.
totalThick
Specifies the thickness of the whole wall.
nComps
Contains the number of components (simple fills) for the composite. The number of separator lines is nComps + 1 because of two contour lines.
filler_1
Reserved for later use.
filler_2
Reserved for later use.

 

Remarks

The flags field of the header describes whether this composite fill can be used for walls, slabs, roofs or shells (APICWall_ForWall, APICWall_ForSlab, APICWall_ForRoof and APICWall_ForShell respectively).

You cannot delete the last composite structure.

There are additional data assigned to composite fill attributes in the API_AttributeDefExt structure; the definition of a composite fill and separator line are passed through the cwall_compItems and cwall_compLItems fields. Refer to the API_CWallComponent and API_CWallLineComponent structure to get more details on it.

Composite structures are referenced from API_WallType, API_SlabType, API_RoofType and API_ShellType with negative fill indices.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Attributes.h

 

See Also

API_Attr_Head, API_Attribute, API_CWallComponent, API_CWallLineComponent, API_AttributeDef,
Attribute Manager, API Types