The representation of a conditional element rule on the Preferences / Calculation Rules tab page.
typedef struct { API_ConditionalElementPropertyTypeID propertyType; double holeLimit; GS::HashSet<API_ElemType> elementTypes; } API_ConditionalElementRule;
Members
- propertyType
- Type of element property to which the rule is applied.
- holeLimit
- Limit of element hole size. Holes smaller than the limit are ignored in calculations.
- elementTypes
- List of element types to which the rule is applied.
Remarks
Valid element types for APIConditionalElementPropertyType_Volume
:
API_WallID
API_SlabID
API_RoofID
API_ShellID
API_BeamID
Valid element types for APIConditionalElementPropertyType_Surface
:
API_WallID
API_SlabID
API_RoofID
API_ShellID
Valid element types for APIConditionalElementPropertyType_Length
:
API_WallID
From version 26 the type of the elementTypes member was changed into GS::HashSet<API_ElemType>.
Requirements
- Version: API 25.0 or later
- Header: APIdefs_Environment.h