Represents a wall or beam connection.
typedef struct { API_Guid guid; bool conWithBeg; bool filler_1[7]; } API_ConnectionGuidItem;
Members
- guid
guid
of the wall, beam, or beam segment connected with its reference line to the given element.- conWithBeg
- The wall, beam, or beam segment is connected with its beginning or the end point.
- filler_1
- Reserve4d for further use.
Remarks
For more details see API_WallRelation, API_BeamRelation, and API_BeamSegmentRelation structures.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h