Parameters of the drawing constraint.
typedef struct { API_ConstraintType constType; Int32 filler_1; double constValue; double filler_2[2]; bool useLocOrigo; bool filler_3; short filler_4[3]; } API_ConstraintPars;
Members
- constType
- Type of the drawing constraint.
- constValue
- The value of the constraint.
- useLocOrigo
- Use the project origin or the last clicked point (locOrigo) as the reference point.
Remarks
For the utilization of API_ConstraintPars
see the APIIo_SetConstraintID interface function.
When fixing the input angle (APIConst_A
), constValue
is defined in radian.
Requirements
- Version: API 6.1 or later
- Header: APIdefs_Interface.h
See Also
APIIo_SetConstraintID
APIIo_ResetConstraintID
API_ConstraintType
API Types