API_​ContentPars

It is used at the APIAny_ChangeContentID goodie function.

    typedef struct {
        API_Elem_Head     head;
        Int32             *from;
        Int32             *range;
        char              *content;
        Int32             *separator;
        double            filler[2];
    } API_ContentPars;

 

Members

head
[in/out] Reference to the element (text or textual label) to be modified, filled with the appropriate new parameters.
from
The beginning byte position(s) in the original content to change.
range
The range(s) of the original content’s pieces to change.
content
New concatenated contents.
separator
The separator byte positions in the concatenated new content.

 

Remarks

See an example of using this structure at the description of APIAny_ChangeContentID.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Goodies.h

 

See Also

API Types, APIAny_ChangeContentID, ACAPI_Goodies