API_​ConvModID

Represents the type of the Archicad object to be saved.

    typedef enum {
        APIConvMod_TextGDL,
        APIConvMod_MemGDL,
        APIConvMod_SymTxtGDL,
        APIConvMod_SymBinGDL,
        APIConvMod_SideGDL,
        APIConvMod_DragGDL
    } API_ConvModID;

 

Members

APIConvMod_TextGDL
Write GDL Text in file (as a macro).
APIConvMod_MemGDL
Convert into 3D model.
APIConvMod_SymTxtGDL
Write as GDL Text in a symbol file.
APIConvMod_SymBinGDL
Write as BINARY in a symbol file.
APIConvMod_SideGDL
Convert to side view.
APIConvMod_DragGDL
Create GDL script to drag-and-drop.

 

Remarks

These options correspond to the formats you can choose while saving something as Archicad object, both from the plan and the 3D window.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Automate.h

 

See Also

API_SavePars_Object, API Types