API_​Coord, API_​Vector

Cartesian (real) coordinate.

    typedef struct {
        double     x;
        double     y;
    } API_Coord, API_Vector;

 

Members

x
Horizontal coordinate.
y
Vertical coordinate.

 

Remarks

It is a real coordinate. Always expressed in meters, if no other instructions are given in the corresponding documentation.

For the integer type representation refer to the API_Point structure, or to the APIDb_PointToCoordID and APIDb_CoordToPointID functions for the conversion algorithms.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Base.h

 

See Also

APIDb_CoordToPointID, APIDb_PointToCoordID, API_Point, API Types