API_​CoverFillTransformation

Fill orientation and distortion parameters.

    typedef struct {
        API_Coord                  origo;
        API_Vector                 xAxis;
        API_Vector                 yAxis;
    } API_CoverFillTransformation;

 

Members

origo
The origo of the fill relative to the center of the element.
xAxis
Primary distortion (direction) vector.
yAxis
Secondary distortion (direction) vector.

 

Remarks

This structure holds the orientation and distortion parameters of the cover fills of API_BeamType and API_ColumnType elements.

 

Requirements

Version: API 23 or later
Header: APIdefs_Elements.h

 

See Also

API_ColumnType, API_BeamType
API_Coord, API_Vector, API Types, API_CoverFillTransformationTypeID