Type of cover fill transformation.
typedef enum { API_CoverFillTransformationType_Global, API_CoverFillTransformationType_Rotated, API_CoverFillTransformationType_Distorted, } API_CoverFillTransformationTypeID;
Members
- API_CoverFillTransformationType_Global
- The fill is linked to Project Origin, the orientation of the hatching is always orthogonal independently of transformations made on the filled element.
- API_CoverFillTransformationType_Rotated
- The fill is linked to Fill Origin, a single handle shows the orientation of the fill, and the fill pattern starts at the origin of the filled element.
- API_CoverFillTransformationType_Distorted
- The pattern of the fill is distorted in x and/or y directions.
Remarks
This structure holds the API_CoverFillTransformation type of the cover fills of API_BeamType and API_ColumnType elements.
Requirements
- Version: API 23 or later
- Header: APIdefs_Elements.h