API_​CrossSectionType

Describes the Structural Analytical Model Cross Section profile type.

    typedef enum {
        API_CrossSection_Rectangle,
        API_CrossSection_Circle,
        API_CrossSection_Attribute
        API_CrossSection_Custom,
    } API_CrossSectionType;

 

Members

API_CrossSection_Rectangle 24
The Cross Section profile is a Rectangle with given width and height.
API_CrossSection_Circle 24
The Cross Section profile is a Circle with a given diameter.
API_CrossSection_Attribute 24
The Cross Section profile is defined in the Profile Manager.
API_CrossSection_Custom 24
The Cross Section profile is a Custom shape.

 

Requirements

Version: API 24 or later
Header: .\APIdefs_AnalyticalModel.h

 

See Also

API Types