API_​CursorFormID

Predefined cursor forms for customizing the user input.

 

API_CursorFormID

 

Description

APICursor_UserDefined

 

Cursor defined by resource ID (NOT USED)

APICursor_Default

 

Default cursor shape

APICursor_Spin

SpinCursor

Spin cursor (rotating beach balls)

APICursor_SystemArrow

 

System arrow cursor

APICursor_SystemClock

 

System clock cursor

APICursor_IBeam

IBeamCursor

I beam cursor for text editing

APICursor_Drag

DragCursor

Cursor for dragging windows

APICursor_Trident

TridentCursor

Trident cursor for dragging rollrect

APICursor_ZoomIn

ZoomInCursor

Zoom in cursor

APICursor_ZoomOut

ZoomOutCursor

Zoom out cursor

APICursor_Hand

HandCursor

Hand cursor

APICursor_MiniHand

MiniHandCursor

Small hand cursor

APICursor_Cross

CrossCursor

Cross cursor

APICursor_Check

CheckCursor

Check cursor (indicates …Neig)

APICursor_CheckRef

CheckRefCursor

Check cursor (thick)

APICursor_Branch

BranchCursor

Branch cursor (indicates …OnNeig)

APICursor_BranchRef

BranchRefCursor

Branch cursor (thick)

APICursor_XPoint

XPointCursor

Cross point cursor

APICursor_Normal

NormalCursor

Normal (perpendicular) cursor

APICursor_Tangent

TangentCursor

Tangent (osculation) cursor

APICursor_Arrow

ArrowCursor

Arrow cursor (selection mode)

APICursor_ArrowCheck

ArrowCheckCursor

Check cursor in arrow mode

APICursor_ArrowCheckRef

ArrowCheckRefCursor

Check cursor in arrow mode (thick)

APICursor_ArrowBranch

ArrowBranchCursor

Branch cursor in arrow mode

APICursor_ArrowBranchRef

ArrowBranchRefCursor

Branch cursor in arrow mode (thick)

APICursor_ArrowXPoint

ArrowXPointCursor

Cross point cursor in arrow mode

APICursor_ArrowNormal

ArrowNormalCursor

Normal cursor in arrow mode

APICursor_ArrowTangent

ArrowTangentCursor

Tangent cursor in arrow mode

APICursor_Pencil

PencilCursor

Pencil shaped cursor during input

APICursor_PencilCheck

PencilCheckCursor

Check cursor during input

APICursor_PencilCheckRef

PencilCheckRefCursor

Check cursor during input (thick)

APICursor_PencilBranch

PencilBranchCursor

Branch cursor during input

APICursor_PencilBranchRef

PencilBranchRefCursor

Branch cursor during input (thick)

APICursor_PencilXPoint

PencilXPointCursor

Cross point cursor during input

APICursor_PencilNormal

PencilNormalCursor

Normal cursor during input

APICursor_PencilTangent

PencilTangentCursor

Tangent cursor during input

APICursor_Eye

EyeCursor

Eye cursor for window/door opening

APICursor_DoubleEye

DoubleEyeCursor

Double eye for window/door position

APICursor_Hammer

HammerCursor

Hammer cursor for completing input

APICursor_MagicWand

MagicWandCursor

Magic wand cursor

APICursor_Trimmer

TrimmerCursor

Scissors shaped cursor

APICursor_TrimmerFull

TrimmerFullCursor

Scissors shaped cursor (thick)

APICursor_Picker

PickerCursor

Dropper shaped cursor

APICursor_PickerFull

PickerFullCursor

Dropper shaped cursor (thick)

APICursor_Injection

InjectionCursor

Injection shaped cursor

APICursor_InjectionFull

InjectionFullCursor

Injection shaped cursor (thick)

 

Remarks

The API_CursorFormID values are used to specify the cursor set for a user input process invoked from the API tool add-on.

For example of using custom cursor sets see APIIo_GetArcID.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Interface.h

 

See Also

API_CursorSet, API_GetPointType, API_GetLineType, API_GetArcType, API_GetPolyType, API Types