API_​CursorSet

Cursor set definition for a user input.

    typedef struct {
        API_CursorFormID     nothingOnCursor;
        API_CursorFormID     pointOnCursor;
        API_CursorFormID     lineOnCursor;
        API_CursorFormID     refPointOnCursor;
        API_CursorFormID     refLineOnCursor;
        API_CursorFormID     crossOnCursor;
        API_CursorFormID     normalOnCursor;
        API_CursorFormID     tangentOnCursor;
        API_CursorFormID     invalpointCursor;
        API_CursorFormID     areaOnCursor;
        API_CursorFormID     lineSurfCrossOnCursor;
        API_CursorFormID     lineSurfNormOnCursor;
        API_CursorFormID     surfSurfCrossCursor;
        API_CursorFormID     surfSurfNormOnCursor;
    } API_CursorSet;

 

Members

nothingOnCursor
The cursor form when the cursor is not above any remarkable point
pointOnCursor
The cursor form when the cursor is above a point neig (except wall neigs on the reference line)
lineOnCursor
The cursor form when the cursor is above a line neig (except wall reference line)
refPointOnCursor
The cursor form when the cursor is above a point neig on wall reference line
refLineOnCursor
The cursor form when the cursor is above the reference line of a wall
crossOnCursor
The cursor form when the cursor is above cross point of elements
normalOnCursor
The cursor form when the cursor is above a line which is perpendicular to the input line
tangentOnCursor
The cursor form when the cursor is above a point of osculation with an arc
invalpointCursor 17
.
areaOnCursor 17
Over area.
lineSurfCrossOnCursor 17
Line and surface cross point.
lineSurfNormOnCursor 17
Normal line points of surface.
surfSurfCrossCursor 17
Cross line of two surfaces.
surfSurfNormOnCursor 17
Two surfaces are normal.

 

Remarks

For example of using custom cursor sets see APIIo_GetArcID.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Interface.h

 

See Also

API_CursorFormID, API_GetPointType, API_GetLineType, API_GetArcType, API_GetPolyType, API Types