API_​CurtainWallType

Represents a Curtain Wall element.

    typedef struct {
        API_Elem_Head                      head;
        API_ZoneRelID                      zoneRel;
        short                              pen;
        short                              filler_1;
        double                             nominalWidth;
        bool                               flipped;
        bool                               filler_2[7];
        double                             offset;
        double                             distanceInside;
        double                             distanceOutside;
        API_CWBoundaryFramePosID           boundaryFramePosition;
        API_LinkToSettings                 linkToSettings;
        API_StoryVisibility                visibility;
        bool                               isAutoOnStoryVisibility;
        bool                               filler_3[3];
        double                             storyRelLevel;
        API_ElemDisplayOptionsID           displayOption;
        API_ElemProjectionModesID          cutProjectionMode;
        API_ElemProjectionModesID          uncutProjectionMode;
        API_ElemProjectionModesID          overheadProjectionMode;
        API_ElemViewDepthLimitationsID     viewDepthLimitation;
        API_AttributeIndex                 overheadLineType;
        short                              overheadLinePen;
        short                              uncutLinePen;
        API_AttributeIndex                 uncutLineType;
        API_AttributeIndex                 frameCutLineType;
        short                              frameCutLinePen;
        short                              panelCutLinePen;
        API_AttributeIndex                 panelCutLineType;
        bool                               useFrameTypesAttributes;
        bool                               usePanelTypesAttributes;
        bool                               filler_4[2];
        API_PenOverrideType                penOverride;
        API_CWPlacementID                  placementMethod;
        Int32                              filler_5;
        API_CWSegmentType                  segmentData;
        API_CWFrameType                    cornerFrameData;
        API_CWFrameType                    boundaryFrameData;
        API_CWJunctionType                 junctionData;
        API_CWAccessoryType                accessoryData;
        double                             angle;
        double                             height;
        API_Polygon                        polygon;
        API_Tranmat                        planeMatrix;
        double                             planeOffset;
        UInt32                             nSegments;
        UInt32                             nFrames;
        UInt32                             nFrameDefaults;
        UInt32                             nPanels;
        UInt32                             nPanelDefaults;
        UInt32                             nJunctions;
        UInt32                             nAccessories;
        UInt32                             filler_6;
    } API_CurtainWallType;

 

Members

head
General element header.
zoneRel
Relation to zones. See API_ZoneRelID.
pen
The pen index.
nominalWidth
Nominal width of the Curtain Wall.
flipped
The curtain wall is flipped.
offset
Panel offset to the reference plane.
distanceInside
Theory border of the curtain wall.
distanceOutside
Theory border of the curtain wall.
boundaryFramePosition
Boundary Frame position.
linkToSettings
Link to story settings. See API_LinkToSettings.
visibility
Story visibility. See API_StoryVisibility.
isAutoOnStoryVisibility
Story visibility will be automatically recalculated when needed.
storyRelLevel
Base level (relative to home story).
displayOption
Floor plan display option. See API_ElemDisplayOptionsID.
cutProjectionMode Featuring API 22
Cut projection mode. See API_ElemProjectionModesID.
uncutProjectionMode Featuring API 22
Uncut projection mode. See API_ElemProjectionModesID.
overheadProjectionMode Featuring API 22
Overhead projection mode. See API_ElemProjectionModesID.
viewDepthLimitation
Floor plan view depth limitation. See API_ElemViewDepthLimitationsID.
overheadLineType
Linetype of view above cutplane on the floorplan.
overheadLinePen
Pen index of view above cutplane on the floorplan.
uncutLineType
Linetype of view below cutplane on the floorplan.
uncutLinePen
Pen index of view below cutplane on the floorplan.
frameCutLineType
Line index of the cut part of frames on the floorplan.
frameCutLinePen
Pen index of the cut part of frames on the floorplan.
panelCutLineType
Line index of the cut part of panels on the floorplan.
panelCutLinePen
Pen index of the cut part of panels on the floorplan.
useFrameTypesAttributes
Use Frame type’s attributes.
usePanelTypesAttributes
Use Panel type’s attributes.
penOverride Featuring API 17
Cut fill pens set in the building material can be overridden on the element level.
placementMethod
Placement method.
segmentData
Curtain Wall Segment related data.
cornerFrameData Featuring API 22
Parameters of corner frames.
boundaryFrameData Featuring API 22
Parameters of boundary frames.
junctionData
Parameters of junctions.
accessoryData
Parameters of glass accessories.
angle
Angle of the curtain wall (input only).
height
Height of the curtain wall (input only).
nSegments
Number of segments.
nFrames
Number of frames.
nFrameDefaults Featuring API 22
Number of custom frame classes (Corner Frame and Boundary Frame Classes are not included).
nPanels
Number of panels.
nPanelDefaults Featuring API 22
Number of panel classes.
nJunctions
Number of junctions.
nAccessories
Number of accessories.

 

Remarks

The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme. By default all CW component is generic and has built from the owner elem.

Featuring API 17   In Archicad 17 the elements’ cut fill foreground and background pens inherit from the building material, and can be overridden on the element level.

Featuring API 22   In Archicad 22, the Frames and Panels of a Curtain Wall element are no longer forced into primary/secondary or glass/glazed categories, with the exception of Boundary Frames, which are still a separate category. As so, the other default Frame and Panel elements are found in the corresponding API_ElementMemo structure. Also, Curtain Wall subelements now contain their own library part identifiers instead of the Curtain Wall structure itself.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWAccessoryCategoryID
API_CWAccessoryType, API_CWFrameType, API_CWJunctionType, API_CWPanelType, API_CWSegmentType
API_AttributeIndex API_Polygon, API_Coord, API_PolyArc, API Types