API_​CutPlanePlanConn

Define the status of the link between the Section/Elevation and the Floor Plan.

    typedef enum {
        APICutPl_Online,
        APICutPl_Offline,
        APICutPl_Drawing
    } API_CutPlanePlanConn;

 

Members

APICutPl_Online
A Section/Elevation will be automatically rebuilt every time it is opened or brought to the front of the screen if the Floor Plan has changed.
APICutPl_Offline
A Section/Elevation is not rebuilt automatically. It can be rebuilt from the model only by calling APIDb_RebuildCurrentDatabaseID function for it.
APICutPl_Drawing
In Drawing status, the elements in the Section/Elevation will be exploded into 2D drawing elements which are not linked to the Floor Plan and will not be automatically rebuilt from the model.

 

Remarks

From Archicad 9 it’s possible to set the status of the link between the Section/Elevation and the Floor Plan (see API_CutPlaneType).

Requirements

Version: API 6.1 or later
Header: APIdefs_Elements.h

 

See Also

API Types
API_CutPlaneType