API_​CutPlaneType, API_​ElevationType

Represents a section or elevation element.

    typedef struct {
        API_Elem_Head                  head;
        API_CutPlaneShowType            cutPlShow;
        short                          storyToShowOn;
        short                          filler_1;
        API_SectionSegment             segment;
        API_CutPlaneMarkerShowType     markerShow;
        API_MarkerLinkDataType         linkData;
        Int32                          filler_2;
    } API_CutPlaneType, API_ElevationType;

 

Members

head
General element header.
cutPlShow
Stories to show cutplane on:
API_CutPlaneShowType Meaning
APICutPl_ShowAll Show on All stories
APICutPl_ShowOnOneStory Show only on one story, setting in storyToShowOn
APICutPl_ShowInRange Show on stories which are in the range
APICutPl_ShowPartRange Show on stories which are in or cut by the range
storyToShowOn Featuring API 17
Story to show cutplane on, if cutPlShow is APICutPl_ShowOnOneStory.
segment 11
Section segment.
markerShow Changed in API 12
Show side markers or middle marker.
linkData
Link information for segments, elevations, details and worksheets.
filler_2
Reserved for further use.

 

Remarks

Most of the original structure members are now in API_SectionSegment

 

Requirements

Version: API 11 or later
Header: APIdefs_Elements.h

 

See Also

API Types