Describes the different calculated values for curtain wall accessories.
typedef struct { GS::uchar_t typeText[API_UniLongNameLen]; double width; double height; double length; double filler[4]; } API_CWAccessoryQuantity;
Members
- typeText
- Junction is always GDL based. This is the name of the GDL object.
- width
- Width of the accessory.
- height
- Height of the acccessory.
- length
- Length of the accessory. (It’s equal to the frame length belongs to plus offset value stored in GDL)
Remarks
See also the curtain wall accessory description in Appendix A of the GDL Reference manual.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h
See Also
ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types